Legit Diablo 2 not working

Page 1 of 4 1, 2, 3, 4  Next

View previous topic View next topic Go down

Legit Diablo 2 not working

Post by Dimebag on Wed Jan 09, 2013 8:50 am

Hello!

I have just joined the forums and have just downloaded D2SE + median XL ultimative (v6b).

When I open up D2SE and choose ''start D2'' my screen freezes and I can see some characters changing on the top left hand corner of my screen. I see these characters appear one after the other: !#$%(),.'" ...etc.

and the game does not boot. I need to CTRL + ALT + DEL to close D2 which is '' not responding''.

I have tried reinstalling D2. it works fine even when I install D2SE and median XL v6b mod. I open median XL mod once...then I cannot open regular Diablo2 anymore.

Anyone knows if I'm doing something wrong? or if I need to modify a file name in order for it to work?

Thank in advance!

Edit: I also tried uninstalling D2SE...and removing all related files. still did not work.
avatar
Dimebag
Asatruar

Posts : 18
Country : ???

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by DanielWolf on Wed Jan 09, 2013 8:55 am

I read about this. It has to do with 1.13c working for mods and 1.13d not working. Try this - enter median and then exit (activates 1.13c), then try to enter classic D2 from the D2SE list on 1.13d. Classic should work.To switch back to median, run the 1.13c classic version in the D2SE list to switch on 1.13c, then exit and re-enter median.

Hope it works
avatar
DanielWolf
Burning Dead

Posts : 1026
Country : Australia

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by Dimebag on Wed Jan 09, 2013 9:02 am

hmmm if you mean from the cores list, I got versions 1.07 LOD vanilla to 1.13c LOD vanilla. I don't have any 1.13d in that list.

Edit: I think I might know what Ive done wrong. would it change something if I added the patch_d2.mpq in the CUSTOMMPQ file BEFORE opening D2SE for the first time? its almost 3:30 am here...so Ill reinstall and try this tomorrow morning...or rather later this morning...lol
avatar
Dimebag
Asatruar

Posts : 18
Country : ???

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by kambala on Wed Jan 09, 2013 2:12 pm

you shouldn't touch the CUSTOMMPQ folder at all. your way to go is the MODS folder.
avatar
kambala
Follower of Akarat

Posts : 1416
Country : Ukraine

View user profile http://worldofplayers.ru/forums/769/

Back to top Go down

Re: Legit Diablo 2 not working

Post by Dimebag on Wed Jan 09, 2013 4:48 pm

@kambala wrote:you shouldn't touch the CUSTOMMPQ folder at all. your way to go is the MODS folder.

I haven't touched it at all. all I did was a fresh D2 install, updated D2, then installed D2SE to my Diablo II folder and then unzip median XL in the MODS folder.
avatar
Dimebag
Asatruar

Posts : 18
Country : ???

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by zerger on Wed Jan 09, 2013 4:57 pm

If you just plan to play medianXL:

fresh D2 install, update to 1.13c, manual install of Mxl (which just requires one file to be replaced)

in any case, back-up the vanilla .mpq for when you want to play vanilla D2 (if so, don't forget to replace the Save folder or you will corrupt your chars)

I don't like using DSE, you don't what have been done to your game folder.


Edit:


Oh sorry, your problem is you cannot play D2 vanilla anymore if you ran Mxl once?

I also have this issue. Two solutions:

1. update to 1.12, not 1.13 (I didn't have this issue with 1.12)

or

2. back up the game.exe just after the fresh install (it should be 1.09). Everytime you want to switch between Vanilla and Mxl, replace the right .mpq + replace your game.exe with the backed-up one then apply the 1.13 patch. That solves the problem on my side
avatar
zerger
Spike Beast

Posts : 430
Country : France

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by Dimebag on Wed Jan 09, 2013 5:43 pm

Ok, So freshly reinstalled D2 again. (mine installs directly on 1.12)

so I kept the original game.exe (1.12) and the patch_d2.mpq (1.12 and i also kept the 1.13)

I ran median XL and my Diablo 2 now does not work. I have then replaced the game.exe and tried both the patch_d2.mpq and now the game just won't even boot. xD

Edit: I have even tried a little test on my own...I have freshly installed Diablo 2 and kept a backup of the fresh install. Both work, I got to start the game from both my original install and the backup install folder I created.

I installed MXL in my original D2 installation folder and kept my backup clean.

Once I open MXL once, both does not work anymore.
avatar
Dimebag
Asatruar

Posts : 18
Country : ???

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by zerger on Wed Jan 09, 2013 5:59 pm

I am not sure you can have 2 legit copies of d2 on the same computer.

Can you try this:

1. fresh install of D2 (again, sorry)

2. Create a folder Backup, and put a copy of game.exe and patch_d2.mpq in it

3. Update to 1.13c

4. Replace patch_d2.mpq with the XML one

5. Start D2 and check MXL is working fine

6. Delete the save folder

7. Replace game.exe and patch_d2.mpq with the backed-up ones

8. Install patch1.13

9. Run D2 and check Vanilla D2 is working


I assume you are not using Plugy
avatar
zerger
Spike Beast

Posts : 430
Country : France

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by Dimebag on Wed Jan 09, 2013 6:39 pm

Ok I have done exactly this and this is what it gives me.

1. Fresh D2 installation

2. backed up game.exe and patch_d2.mpq (edit: these are 1.12 since the battlenet client installs directly 1.12)

3. (not sure about this one) I have updated to 1.13c by launching ''1.13c vanilla LOD'' from D2SE. (is this what I was supposed to do?)

4. replaced patch_d2.mpq with the one found in ''median XL - ultimative'' folder

5. started D2 on median XL ultimative. says ''unable to identify version'' when I try to connect.

6. deleted the save folder from ''median XL - ultimative'' folder.

7. replaced both game.exe and patch_d2.mpq with the ones I've backed up after the fresh D2 install.

8. could not install patch 1.13 since D2 does not work.

I tried both checking and unchecking plugy. did not work.

* Even after I had replaced the original patch_d2.mpq and game.exe, both vanilla D2 and MXL did not work. MXL says ''unable to identify version''.

I am doing this on Windows 7 professional 64bit.

Edit: maybe this might help solve the issue...I am not installing D2 with the disks. I have downloaded the client directly from battle.net and installing D2 + LOD with the battlenet client.
avatar
Dimebag
Asatruar

Posts : 18
Country : ???

View user profile

Back to top Go down

Re: Legit Diablo 2 not working

Post by zerger on Wed Jan 09, 2013 7:31 pm

@Dimebag wrote:

5. started D2 on median XL ultimative. says ''unable to identify version'' when I try to connect.

Connect to what? Battlenet? That won't work as the mod modify the files game.

I am sorry, I don't have other idea about your problem Sad
avatar
zerger
Spike Beast

Posts : 430
Country : France

View user profile

Back to top Go down

Page 1 of 4 1, 2, 3, 4  Next

View previous topic View next topic Back to top


 
Permissions in this forum:
You cannot reply to topics in this forum